button-texticon-angleicon-arrow-bottomicon-arrow-footericon-arrow-lefticon-checkicon-circleicon-closeicon-crossicon-facebookicon-hatebuicon-instagramicon-lineicon-linked_inicon-mailicon-pinteresticon-plan-01icon-plan-02icon-plan-03icon-pocketicon-tagicon-twittericon-youtubelogo-simple
now
イラストのテイストを着せ替える
サイト内のイラストを
あなたの好みに変えられるよ!
テイストをいろいろに
変更しました
テイストをマンガに
変更しました
テイストをミニキャラに
変更しました
クリスタの選択範囲を使いこなそう!選択範囲の基本から応用まで
クリスタの選択範囲を使いこなそう!選択範囲の基本から応用まで

選択範囲は、絵のバランスを整えたりはみ出さずに色を塗ったりできて便利です。
でも使い方がわからないと、絵を描くのにどう役立つかもいまいちピンと来ませんよね。

選択範囲は「選択範囲ランチャー」を活用すれば自在に使いこなせます!
歪んだパーツを整えたい時や移動させたい時に描き直しせずに調整できて便利です。

選択範囲の使い方を覚えて描きたい絵に近付けましょう。

選択範囲って何?基本の操作方法をじっくり解説

選択範囲の基本操作

選択範囲とは、イラストや漫画の編集したい部分を指定する範囲のことで、

選択範囲をつくれば、マウスやペン先でドラッグした範囲のみ編集できます。

egaco
はみ出さずに絵を描きたい時、部分的に動かしたい時に選択範囲は便利ですね。

クリスタには長方形や楕円形といった図形で選択範囲を作るツールや、投げなわ選択や折れ線選択など自由なかたちで選択範囲を作成できるツールがあります。

選択範囲の種類の解説
  1. 長方形選択 ・・・ 四角形で選択できます
  2. 楕円選択 ・・・ 楕円形で選択できます
  3. 折れ線選択 ・・・ 直線で選択できます
  4. 投げなわ選択 ・・・ フリーハンドで選択できます
  5. 選択ペン ・・・ ペンで描くように選択できます
  6. 選択消し ・・・ 消しゴムで消すように選択範囲を除外します
  7. シュリンク選択 ・・・ 囲った範囲内にある絵の外周に沿って選択できます

選択範囲を作成するには

図形の選択範囲の操作

図形による選択範囲は、囲いたい範囲の右上や左上にカーソルをあわせて対角線になるよう斜めにドラッグすると上手に囲えます。

折れ線選択の操作の説明

折れ線選択は、マウスやペン先で画面に点を打つように選択範囲を繋げていきます。

選択範囲を閉じたい時、スタート地点に向かってカーソルをあわせると小さく「〇」が表示されたらそのままクリックして完了です。

途中で解除する時はダブルクリック、またはペン先ですばやく2回画面をタッチしましょう。

投げわ選択の説明

編集したい部分より少し広い範囲を囲いましょう。
囲いきるまでマウスのドラッグやペン先を離さないように注意です。

また一回で上手くいかなければ、追加選択を使ったり再選択してみたり自分に合った方法で使ってみましょう。

シュリンク選択で簡単!選択範囲作成

シュリンク選択の説明

シュリンク選択は、描いた絵をぐるっと囲えばアウトラインにぴったり沿った選択範囲が作れます。
全体が収まるように大きく囲いましょう。

線や塗りが途切れていると上手く選択されない場合があるので注意しましょう。

egaco
選択範囲で作って編集しおわったら、選択を解除するまでが一連の使い方です。 選択範囲を「解除」したり「反転」したりする方法を覚えましょう。

選択範囲ランチャーを使いこなして素早く選択範囲作成

選択範囲ランチャーの解説

選択範囲を使い終わったら解除しましょう。
選択の解除は、選択範囲を作るとすぐ下に表示される「選択範囲ランチャー」から使えます。

選択範囲には細かい手順を重ねた使い方もありますが、選択範囲ランチャーを使えば表示されたアイコンを選ぶだけで操作をショートカットできます。

  1. 選択を解除 ・・・ 選択範囲を解除します
  2. キャンバスサイズを選択範囲に合わせる ・・・ キャンバスを選択範囲でトリミングします
  3. 選択範囲を反転 ・・・ 選択範囲を反転します
  4. 選択範囲を拡張 ・・・ 選択範囲を任意のサイズで拡張します
  5. 選択範囲を縮小 ・・・ 選択範囲を任意のサイズで縮小します
  6. 消去 ・・・ 選択範囲内を消去します
  7. 選択範囲外を消去 ・・・ 選択範囲外を消去します
  8. 切り取り+貼り付け ・・・ 選択範囲内の絵を切り取って新規レイヤーに貼り付けます
  9. コピー+貼り付け ・・・ 選択範囲内の絵をコピーして新規レイヤーに貼り付けます
  10. 移動と変形 ・・・ 選択範囲内の絵を変形します
  11. 塗りつぶし ・・・ 選択範囲内を塗りつぶします
  12. 新規トーン ・・・ 選択範囲内を塗りつぶしたトーンレイヤーを作成します
選択範囲のコマンドバー

特によく使う「選択を解除」や「選択を反転」といった操作は、メインウィンドウ上部のコマンドバーでも使えます。
操作を間違えた場合は、取り消しを押してからリトライしましょう。

複数選択や部分解除したい場合は、ツールプロパティを使おう

ツールプロパティの解説

選択したい箇所が2つ以上あったり、連続して囲いたい場合はツールプロパティから設定しましょう。

  1. 新規選択 ・・・ 新規に選択範囲を作れます。
  2. 追加選択 ・・・ 作られた選択範囲を追加で作れます。
  3. 部分解除 ・・・ 作られた選択範囲を部分的に解除できます。
  4. 選択中を選択 ・・・ 作られた選択範囲と重なる部分だけを選択範囲とします。

選択方法の「追加選択」を選べば連続して複数の選択範囲が作れます。
一部分だけ解除したいなら「部分解除」を選択して不要な範囲のみ解除できます。

また2つの選択方法には、ショートカットキーがあるので覚えて使ってみましょう。
「Shiftキー」を押しながら使うと追加選択に切り替わります。
「Altキー」を押しながら使えば部分解除になります。

もっと高度な選択をしたい時は、選択範囲を使ってみよう

選択範囲メニューの解説

より高度な操作をしたい場合、メインウィンドウ上部のメニューの「選択範囲」から使ってみましょう。

  1. すべてを選択 ・・・ キャンバスをすべて選択します
  2. 選択を解除 ・・・ 選択範囲を解除します
  3. 再選択 ・・・ 直前で解除した選択範囲を復帰します
  4. 選択範囲を反転 ・・・ 選択範囲を反転します
  5. 選択範囲を拡張 ・・・ 選択範囲を任意のサイズで拡張します
  6. 選択範囲を縮小 ・・・ 選択範囲を任意のサイズで縮小します
  7. 境界をぼかす ・・・ 選択範囲の境界をぼかします
  8. 色域選択 ・・・ 任意のカラー部分だけを選択します(後述)
  9. 選択範囲にかかるベクターを選択 ・・・ 選択範囲にかかるベクターレイヤーの中心を選択します
  10. 選択範囲に含まれるベクターを選択 ・・・ 選択範囲に全体が含まれるベクターレイヤーを選択します
  11. クイックマスク ・・・ 描画するように選択範囲を作ります
  12. 選択範囲をストック ・・・ 選択範囲をレイヤー毎に保存できます(後述)
  13. ストックから選択範囲を復帰 ・・・ 選択範囲レイヤーに保存された選択範囲を復帰します

クイックマスクについてはこちらのトーンについての記事をご覧ください。

クリスタのデジ絵トーンの貼り方講座!トーン次第で漫画が変わる
クリスタのデジ絵トーンの貼り方講座!トーン次第で漫画が変わる

応用編!クリスタの自動選択や色域選択で選択範囲は自由自在

自由な形の選択範囲や、より限定した部分だけで選択したい方は「自動選択」や「色域選択」を活用しましょう。
知っておくと時短に繋げられたり、繊細な絵を仕上げるのに便利です。

自由な形に選択したいなら「自動選択」

自動選択のサブツール

「自動選択」は、ペン先やマウスでクリックした部分にあわせて作られる選択範囲です。

画像のような絵の細かい箇所は、投げなわ選択や選択ペンを使っても、はみださずに選択するのは骨が折れます。

画面を拡大して、自動選択でクリックしていけば余白にぴったりあった選択範囲が簡単に作れます。

自動選択のサブツールについての説明

「自動選択」には、サブツールが3つ設定されています。

「編集レイヤーのみ参照選択」は、選んだレイヤーを参照して選択範囲を作りますので、別レイヤーで描かれた線や塗りが選択範囲に影響しません。

キャンバスに表示されたすべての線や塗りを参照したい場合は「他レイヤーを参照選択」に切り替えましょう。

自動選択の参照レイヤー

参照したいレイヤーが複数ある場合には、選択したいレイヤーをすべて「参照レイヤー」に設定したのち「参照レイヤー用選択」を使えば設定したレイヤーだけが選択範囲に影響します。

選んだ色だけを選択したい場合は「色域選択」

色域選択を選択

部分的に色を変更したい場合は「色域選択」で変えたい色だけ選択してみましょう。
メインウィンドウ上部の選択範囲メニューから色域選択が選べます。
たとえば画像の「青い」部分だけを変更してみましょう。

色域選択を選択

対称の画像レイヤーを選び、色域選択を使います。
ダイアログが表示されてカーソルがスポイトに変わりますので、選択したい色部分をクリックしましょう。

色域選択の解説

①の「色の許容誤差」は、数値が高いほど似通った色も含めて選択できます。
数値が低いほど選んだ色だけに限定して選択できます。
また選択したい範囲が複数ある場合は、②のスポイトのマークから選択タイプを切り替えましょう。

  1. 新規に選択 ・・・ 新しく選択範囲を作ります。
  2. 選択に追加 ・・・ すでに選択された部分以外を追加で選択します。
  3. 選択から解除 ・・・ すでに選択された部分から任意の選択を解除します。

別レイヤーの色もいっしょに選択したい場合は、③の複数参照を設定しましょう。
今回は、選択されたレイヤーのみで選択範囲を作ります。

  1. すべてのレイヤー ・・・ 表示されたすべてのレイヤーから選択します。
  2. 参照レイヤー ・・・ 参照レイヤーに設定されたレイヤーから選択します。
  3. 選択されたレイヤー ・・・ 選んだレイヤーのみから色を選択します。
  4. フォルダー内のレイヤー ・・・ 参照レイヤーの格納されたフォルダから選択します。
指定した色部分に選択範囲が作られました

指定した色部分に選択範囲が作られました。
画像に見える青い部分すべて選択されているか確認しましょう。
選択範囲をやり直したい場合は、ダイアログ左下の④のリセットを押せば選択し直せます。

レイヤーから選択範囲を作成する方法

レイヤーから選択範囲を作成

描画した領域をそのまま選択範囲として取り込めます。
たとえば画像の「肌色」だけを選択してみましょう、レイヤーパレットから選択範囲を作りたいレイヤーを選びます。

レイヤーから選択範囲の解説

メインウィンドウ上部のレイヤーメニューから「レイヤーから選択範囲」を選びましょう。

  1. 選択範囲を作成 ・・・ 描画した部分を選択します
  2. 選択範囲を追加 ・・・ すでに選択された部分以外を追加で選択します。
  3. 選択範囲を削除 ・・・ すでに選択された部分から任意の選択を解除します。
  4. 選択範囲から選択 ・・・ すでに選択された部分内で選択範囲を作ります。
レイヤーから選択範囲を作成

レイヤーパレットにある任意の表示レイヤーを直接右クリックもしくはCtrlキーを押しながらクリックしても選べます。

選択範囲を作成を選んで完了

1枚のレイヤーから選択範囲を作りたいなら「選択範囲を作成」を選んで完了です。
フォルダや複数レイヤーから作成したい時は、任意のレイヤーを選択してから作成すると一括で選択範囲が作れます。

何度も同じ形で選択範囲を選択したい場合は、選択範囲をストックを使おう

選択範囲をストック

何度も同じかたちで選択範囲を作るのは大変ですね。
クリスタでは一度作った「選択範囲をストック」できます。

作った選択範囲を解除しないで、選択範囲メニューから選択範囲をストックを押します。
選択範囲が緑色で表示され、レイヤーパレットに「選択範囲レイヤー」が作られます。

非表示や削除しなくても印刷には出ませんし、不要になれば通常レイヤーと同じように削除できます。

ストックから選択範囲を復帰

ストックした選択範囲を使いたい時は、「ストックから選択範囲を復帰」を使います。
選択範囲レイヤーを選んだまま、選択範囲メニューから復帰を選ぶと同じかたちで選択範囲が作られます。

複数の選択範囲を復帰させたい場合

選択範囲レイヤーが複数あってすべての選択範囲を復帰させたい場合は、選択範囲レイヤー以外(用紙や新規レイヤー)を選べばすべての選択範囲が復帰します。
非表示にされた選択範囲レイヤーは読み込まれないため、作りたい範囲にあわせて使い分けましょう。

また選択範囲レイヤーの緑色のサムネイルをダブルクリックする方法や、ご紹介した「レイヤーから選択範囲」でも簡単に復帰できます。

変形や塗りつぶしと選択範囲を組み合わせよう

イラストの線画の調整や部分的に色を塗りたい時こそ、選択範囲が大活躍します。
実際に線画の大きさを変えたり動かしたり、色を塗ってみましょう。

部分的にパーツの大きさを変えたいなら、選択範囲と変形を使おう

選択範囲の変形でパーツの大きさを変えよう

画像の絵は、左右で目の大きさが違ってしまいました。
せっかく上手に描けた目を描き直すのはもったいないですね。

選択範囲を使えば部分的にサイズを変えられます、投げなわ選択で目だけを編集してみましょう。

投げわ選択で目だけを編集してみよう
変形してみる。拡大縮小してみる

選択範囲ランチャーの右側にある「拡大・縮小・回転」を選びましょう。

ハンドルが表示されますので、ドラッグしながら上下左右に動かして適切な大きさにします。
角度を変える時は、ハンドルの角にカーソルをあわせて任意の方向にドラッグして回転できます。
またハンドル内の余白にカーソルをあわせると十字カーソルに変わり、好きな場所へ移動できます。

大きさを変えて確定

大きさを整えたら確定を押して完了です。
やり直したい時は、キャンセルを押してもう一度同じ手順で編集してみましょう。

部分的に色を塗りたい場合は、選択範囲と塗りつぶしを合わせて使おう

選択範囲で部分的に色を塗ろう

画像のようなキャラクターのシルエットにあわせて選択範囲を作ってみましょう。

余白部分を自動選択して「選択を反転」してみましょう。
反転は、①の選択範囲ランチャーまたは②のコマンドバーにあるアイコンを押すか、③のメインウィンドウ上部の選択範囲メニューから選べます。

色々な表現にも使える

キャラクター部分だけ選択できましたね。
新しいレイヤーを作って塗りつぶせば絵の下地に使えたり、好きな色を塗って移動ツールでずらすと影が落ちた表現にも使えたりします。

使い方をおぼえれば、描きたい絵に近づけられますね。
どんどんデジタルツールを活用しましょう。

選択範囲は、使い方次第で無限大!

選択範囲は使い方次第で無限大

いかがでしたでしょうか。
選択範囲を使って絵を調整すれば、自分の描きたかった絵にぐっと近づけられます。

でも使い方のコツが掴めなかったり操作が覚えづらかったりすると、いくら便利と言われても敬遠しますよね。
もっと上手に使いこなしてみたい方は、egacoの専門講師といっしょに使い方を学んでみませんか?

まずは無料体験へお気軽にお越しください。

無料体験のお申込み
無料体験のメリット
  • 教室の雰囲気や講師の人柄を確認できる!
  • 個別に受講内容提案をしてもらえる!
お名前
メールアドレス
電話番号
生年月日
性別
体験校舎
受講日
受講時間
その他ご要望など
個人情報の取り扱いについて
「プライバシーポリシー(個人情報保護方針)」をご確認いただき、
同意の上、以下の「同意する」にチェックして「入力内容の確認へ」ボタンを押してください。
egaco編集部
この記事を書いた人
egaco編集部先生
Profile
イラスト・マンガ教室egacoです。初心者の方にもわかりやすく、描き方や上達に役立つ情報を発信しています。